Welcome to the latest Adobe Photoshop CC bulletin update. This is provided free to ensure everyone can be kept up-to-date with the latest changes that have taken place in Photoshop CC.

This bulletin describes the latest changes to the main Photoshop program. For a complete description of how to use these new Photoshop tools, with diagrams and step-by-step tools, I recommend you buy the Adobe Photoshop CC for Photographers book.

The 2014.1 update was all about 3D features. However, the 2014.2 update does contain a lot interesting new features such as the ability to create libraries of design elements, tree and flame effects, new layout guide options as well as a number of other useful refinements.
**New Welcome experience**

The first thing you will notice is the new splash screen, which now has a 1080p ratio. Once Photoshop has launched you will then see the Welcome screen shown in Figure 1 below. This has several tabs such as the New Features section shown in Figure 1. This contains tutorials to help you learn about some of the new tutorials in Photoshop. The Create section (Figure 2) offers a list of new document presets plus an Open Recent list of documents you have opened most recently in Photoshop. At the bottom of the Create panel are links you can use to get further help or information about the program.

![New Welcome experience](image.png)

**Figure 1** The Welcome screen showing New Features.

![New Welcome experience](image.png)

**Figure 2** The Welcome screen showing the Create options.
**Improved Guides**
This new release sees the addition of two new guide submenu items in the View menu (see Figure 3).

**New Guide Layout Dialog**
The View -> New Guide Layout dialog can be used to create multiple guides at once. Using the New Guide Layout dialog you can specify columns, rows, gutters and margins and save and custom layouts as presets. Figure 4 shows the New Guide Layout dialog using the default 8 column setting, which is shown below in Figure 6. You can choose different column settings from the preset menu (Figure 5).

![Figure 4](image.png)
*Figure 4* The New Guide Layout dialog

![Figure 6](image.png)
*Figure 6* An example of an image with a new guide layout added.

![Figure 3](image.png)
*Figure 3* The View menu showing the New Guide Layout and New Guides From Shape options.

![Figure 5](image.png)
*Figure 5* The New Guide Layout dialog Preset menu options.
**New Guides from Shapes**

The New Guides From Shape menu option allows you to quickly create guides according to the edges of selected layers and selected shapes within a shape layer, as shown in the steps below. Hidden layers should always be ignored.

1. This shows a layout in Photoshop made up of two background gradients, two logo layers and an arrow shape layer.

2. In this step I selected the Photoshop icon layer group and chose View ➤ New Guides from Shape. This added the guides shown here.

3. Next, I selected the Arrow shape layer group and again chose View ➤ New Guides from Shape. This added more guides based on the arrow shape outline.
**Creative Cloud Libraries**

New to Photoshop, as well as to several other programs in the Creative Cloud, is the Libraries panel. To access, choose Window ⇒ Libraries. This is a panel you can use to hold library collections of graphic assets, text styles, layer styles and colors (see Figure 7). As you work on a project you can click on the buttons at the bottom of the panel to add any of these items to build a library of design elements associated with a particular job. You can then save these as individual creative libraries, to be reused on other, similar projects. Libraries can be accessed and used on a single offline computer. However, they are also synced to your Adobe ID account, which means they can be easily shared with other machines that share the same user account. And as I mentioned at the beginning, library items can be shared across other Adobe programs. Essentially, this feature is like a super clipboard. Normally when you copy something only one item can be stored at a time in the clipboard memory. Using libraries you can use this as a place to store multiple design elements. In the Figure 8 example I used the Libraries panel to store a number of graphic assets that were associated with a house build project, along with a few custom color samples. When loaded I could simply drag and drop graphic elements from this panel, or click on a color sample to load as the foreground color.

**Figure 7** This shows the Libraries panel where in the top screen shot I clicked on the top menu to select ‘Create new Library…’ The bottom panel shows how I was then asked to name the new library.

**Figure 8** This shows the Libraries panel with Colors and Graphics elements added for a project I was working on.
**Extract Assets**

The Extract Assets feature is an extension of the Generator feature, which allows you to export individual layers from an image document and have them update automatically whenever the original source design changes. To extract assets open a layered PSD image and select the layers you want to create assets for. Next, choose File ⇨ Extract Assets… Alternatively, use a right mouse click to open the layers context menu and select ‘Extract Assets…’, or use the `⌘` + `⌥` + `Shift` + `W` (Mac) `Ctrl` + `⌥` + `Shift` + `W` (PC) keyboard shortcut. This opens the Extract Assets dialog which will by default creates PNG assets for the selected layers, and these will be listed in the Extract Assets section. However, you can choose other file formats via the drop down menu circled in Figure 9 below. Once you are ready to extract assets, click on the Extract… button. This will ask you to choose a location to save your assets. Once the assets have been extracted a Finder/File System window will open showing the assets that have been created. Clicking ‘Done’ will save the settings and

---

**Adding additional assets**

To add additional assets, select the layer you want additional assets for and click on the icon which is adjacent to the layer name. You can choose from: PNG-8, PNG-32, PNG-24, JPG, GIF, or SVG. Click on the icon that’s next to an asset to expand the interface that allows you to customize the dimensions you want to scale the assets to. To remove, click on the trash icon that’s next to the asset to remove the asset for that layer.

---

**Figure 9** The Extract Assets dialog.
choices you have made for asset extraction. This is done by renaming layers and layer comps to use the Generator Syntax. If you do not want any of these changes to persist, and want to abandon your work, click ‘Cancel’.

You can then choose what resolutions you want to generate the assets as via the Settings panel or within the ‘Extract Assets’ tab (see Figure 9). For example, you might want to create assets at a 1x scale and also at a 2x scale. Therefore, you can set the resolution you are designing at in the top section. This determines the default resolution when creating assets. If you want to extract assets at additional resolutions, you can do this via the Settings dialog shown in Figure 10 (click the button in the bottom left of the Extract Assets dialog). For example, if you want to output a 2x version of the assets into a different folder, you can name the folder accordingly.

In the Settings dialog is an ‘Automatically generate assets when updating document option’. When selected, assets will be automatically saved alongside the Photoshop document in a separate folder named after the master PSD file. The assets in this folder will be continuously regenerated when any of the layers you want assets for are updated in that document.

Figure 10 The Extract Assets Settings dialog.
**Flame filter**

The ability to work with scripted patterns was around in Photoshop before, but is now made more evident in the program through the addition of three new items in the Filter ➞ Render menu: Flame, Picture Frame and Tree. Let’s look at the flame generation first, which allows you to create realistic flame effects based on a user-defined path or paths.

When the filter settings are applied correctly it can produce flames that are rather realistic. You could say they pass the Photoshop Turing test, where the end result can be good enough to convince viewers the added flames are real. The trick is to start by defining a path or paths that the flames can follow and know how to manage the slider controls to produce the desired flame effect. This filter is not compatible with Smart Objects, so you have to rely solely on the preview as you adjust the settings and click OK to see what the final outcome will look like. If you want to fine-tune the filter effect my suggestion is to undo the filter and reapply by holding down the `alt` key as you reselect ‘Flame’ from the top of the Filter menu. This will reload the filter with the last used settings. Readjust and apply again. To save time you can choose a low quality render setting first and reapply using a higher quality render setting. The following steps show how I was able to add some extra flames to a photograph of a freshly lit barbecue.

1 Here is a photograph of a barbecue fire about to catch light. To prepare this image to add more flames, I selected the pen tool and drew a number of open paths.
2 I added an empty new layer above the Background layer and chose Filter ➔ Render ➔ Flame… This opened the Flame dialog, where I entered the settings shown here to create the desired flame effect and sampled colors from the flames in the actual image.

3 This shows the final image with the extra flames added to the separate layer.
**Flame filter controls**

The flame effect can be modified by first selecting an option from the Flame Type menu (see Figure 11). The Length slider and Randomize Length check box will only become active when one of the multiple flame style options is selected. The Width slider controls the pixel width of the flame effect, while the Angle slider determines the flame angles when the following flame styles are selected: Multiple Flames One Direction, Multiple Flames Path Directed or Multiple Flames Various Angle. The Interval slider is active when any multiple flame style is selected. Increasing the Interval creates wider gaps between the flames. If the path forms a loop, checking the Adjust Interval for Loops option ensures the gap between the flames will be uniform or even. The flame effects are constructed with lines. Increasing the Flame Lines increases the complexity of the flame effect. The Turbulent slider determines how rough or how smooth the flame effect will be. A low Jag setting will produce a smoother effect and a higher setting appear more jagged. The Opacity slider can be used to control the brightness of the flame effect. It is important to ensure the flame effect is not too bright, or else the flame highlights will be clipped. One thing to watch out for is the way the Opacity slider also affects the flame shape as you adjust the slider. With the Flame Bottom Alignment slider, when this is set to zero, each of the lines that create the flame will be evenly aligned. As you increase the slider setting they will be more randomized.

There are three Flame styles. These are shown in Figure 12 and include Normal, Violent or Flat. As you can see these alter the characteristics of the flame effect. The Flame Shape menu has the following options: Parallel, To The Center, Spread, Oval and Pointing. These options determine the overall shape of the flame effect. The default color is very flame-like, but if you are attempting to match existing flames in a photograph you can do what I did in Step 2 on the preceding page, where I checked the Use Custom Color for Flames option. This popped a color picker, which allowed me to sample the flame colors in the photo and use these to render flames that matched even more closely the real flames. The Quality menu allows you to select the desired render setting. When adjusting the sliders it can help to have this set to Draft mode. When it comes to rendering the final effect you can choose a higher quality setting. Lastly there is the Randomize Shapes button. When checked, the flame shape will be different every time a flame is created. When unchecked you can adjust the Arrangement slider to generate slightly different types of flame effect.

**Figure 11** The Flame Type options include One Flame Along Path (top) and Multiple Flames One Direction (bottom).

**Figure 12** The Flame Style options include Normal (top), Violent (middle) and Flat (Bottom).
**Tree filter**
The Tree filter uses the same rendering script process as the Flame filter, but to generate different types of trees. Unlike the Flame filter this isn’t likely to pass the Photoshop Turing test, but even so the results are pretty good. The results are not quite good enough to look photo-realistic, but if you were to blur the results when adding to a blurred background, the rendered trees can look quite realistic. Otherwise, it is perhaps more a tool for illustrators. At the top of the dialog there is a Base Tree Type menu, where you’ll find a list of 34 different tree types. You can then choose to adjust the Light Direction, the Camera Tilt to set the viewing angle and adjust the Leaves Amount and Leaves Size. Below that are sliders to control the Branches Height and Branches Thickness.

The following steps show how I was able to use the Tree filter to create trees that would blend into a landscape photo.

1. I added an empty new layer above the image layer and chose Filter ➞ Render ➞ Tree… This opened the Tree filter dialog, where I entered the settings shown here to build the desired tree shape.

---

**The Turing test**
Alan Turing, the inventor of the modern computer devised a test to determine if a computer in the future could be said to have artificial intelligence. Essentially, a satisfactory test would be to see if a computer operator in a blind test could tell if the responses they got to questions they asked were from a machine or from a real person.
2 I also clicked on the Custom Color for Leaves and Custom Color for Branches buttons to open the color picker shown here to sample colors from the trees in this photograph so that the leaves and branch colors would match.

3 This shows the finished result, where I also added a second tree and copied the shadows of the other trees to make these appear to match the rest of the scene. I also converted the rendered layer to a smart object and applied a very small amount of Gaussian Blur to soften the texture of the trees slightly so they matched all the other trees.
**Tree filter checkbox options**

Below the sliders are a number of checkboxes (Figure 13). When the Default Leaves option is checked the tree will be generated using the leaves linked to the selected base tree type. If you uncheck this you can select other leaf types in order to create your own custom hybrid tree type. As was shown in the previous step-by-step example, you can check the Use Custom Color for Leaves and Use Custom Color for Branches options to set custom colors for both. The Flat Shading – Leaves and Flat Shading – Branches options apply a flat tone fill to either the leaves or branches. The Enhance Contrast – Leaves option mostly adds more texture contrast to the leaves. Leaves are normally rotated in three dimensions. If you check the Use the Leaves Rotation Lock option box, you can stop the leaves rotating three dimensionally. This will produce more illustration-like results. Lastly, when Randomize Shapes is unchecked, you can adjust the Arrangement slider to apply different seed values to generate different tree shapes.

![Figure 13 The Tree filter dialog](image-url)
Shortcuts preferences and menu updates
A few minor changes have been made to the layout of the Preference panels in this latest release. For example, Scratch Disk preferences have now been separated from the Performance preferences section. In the Interface preferences (Figure 14), there is a new item called ‘Overscroll’. If this is enabled it means that when you are working in a regular document window, you now have the ability to overscroll the image to reveal the outer canvas area. Previously you could only access this while in one of the full screen view modes.

In addition to this, holding ⌘ (Mac) Ctrl (PC) with the move tool selected toggles the auto-select option to auto-select layers or layer groups. There is a new keyboard shortcut for locking layers (⌘ / Mac) Ctrl / (PC), a new keyboard shortcut for hiding layers (⌘ + , [Mac] Ctrl + , [PC]) and a new Layers panel menu item ‘Collapse All Groups’ to collapse all layer groups in a layered image document.

![Figure 14](image.png) The Interface preferences showing the new Overscroll item.
**History panel saves**
Document saves are now recorded in the History panel (Figure 15). This doesn’t mean that history states are saved after you close a document of course, but it does mean that Photoshop will automatically store a history state each time you save, which will give you more options to revert to during an edit session.

**Mercury Graphics Engine performance boost**
The Mercury Graphics Engine has made a significant improvement in providing GPU acceleration for the Focus Area feature.

**Adobe Color Themes panel**
The Adobe Color Themes panel (Figure 16) restores Kuler functionality to Photoshop. Kuler was removed when Photoshop CC was first released due to the removal of Flash support from Photoshop. This panel provides the same level of functionality allowing users to explore lots of different color combination themes as well as create their own custom themes.

**Improved user interface for Fill dialogs**
Some subtle changes have been made to the Fill and Fill Path dialogs. Figure 17 shows how the Content-Aware options now only show up when the Content-Aware menu item is selected.

**Canvas bounds options for modifying selections**
When going to the Select ➤ Modify menu, the Smooth, Expand, Contract and, Feather commands now have an Apply effect at canvas bounds option. In Figure 18 this option was checked in the Feather Selection dialog, which meant that the feathering would be unconstrained by the limits of the canvas area, which would be the case is this option were unchecked.
**Instant layer grouping**
If you select a number of layers and then click on the Create a new group button at the bottom of the Layers panel, this automatically puts the selected layers in the new group. This now provides a shorthand alternative to choosing Layer ➔ New ➔ Group from Layers… menu command and also sidesteps seeing the interim New Group from Layers dialog.

**Content-aware Patch and Move**
The Options bar layouts for the Content-aware Patch and Content-aware Move tools have been updated (Figure 19). The gearwheel icon is gone and in place the Structure and Color options are accessible directly from the Options bar.

![Figure 19](image)
This shows the new look content-aware patch tool Options bar (top) and new look content-aware move tool (bottom).

Improvements have also been made to the algorithm for the content-aware features. Figure 20 shows a comparison of the outcome when making a selection of some clouds and choosing Edit Fill using the Content-aware mode with the Color Adaptation option checked. As you can see the results using this latest version are somewhat smoother.

![Figure 20](image)
A comparison of the Photoshop CC 2014 and Photoshop CC 2014.2 Content-aware fill command in use.
Support for Windows touch devices
This latest version of Photoshop CC supports Windows 8.1 touch devices such as the Microsoft Surface Pro. This means you can now use gestures to zoom, pan or rotate when working in Photoshop.